Supported RabbitMQ versions

The AiiDA documentation currently states

RabbitMQ v3.5 and older are end-of-life and are not supported in any way. For RabbitMQ v3.8.15 and up, AiiDA is not compatible with the default configuration of the server.

This is outdated, if you follow the link all version below 3.11 are unsupported. In fact, since RabbitMQ is part of VMWare, which was recently acquired by Broadcomm, you’ll see this “friendly” message.

From June 1st, 2024 and onwards, the RabbitMQ Core Team at Broadcom only provides support to paying customers and regularly contributing users.

In practice, the “community support” only covers the latest released version.

As a near-term action item, should we update the testing matrix in .github/workflows/rabbitmq.yml, drop the old versions (3.6, 3.7) and test 3.8, 3.9, 3.10?

Are some people actually using versions >3.8? Which ones? In AiiDAlab, we control the RabbitMQ configuration, so it would make sense to us to use a newer version, but I don’t know which versions are battle-tested and known to work. 3.9 is probably safe? (we use 3.9.13 for our ARM64 build)

Thanks for raising this @danielhollas! I’m using 3.13.2, installed with brew on MacOS, and then configure the consumer_timeout as described here:

1 Like

Thanks @mbercx, that’s very helpful to know!

As a near-term action item, should we update the testing matrix in .github/workflows/rabbitmq.yml, drop the old versions (3.6, 3.7) and test 3.8, 3.9, 3.10?

This has been done in