# Unnable to connect to broker issue (Aiida 2.6.1)

**URL:** <https://aiida.discourse.group/t/unnable-to-connect-to-broker-issue-aiida-2-6-1/608>\
**Category:** General Usage\
**Tags:** rabbitmq\
**Created:** [May 6, 2025, 3:08pm UTC](https://aiida.discourse.group/t/unnable-to-connect-to-broker-issue-aiida-2-6-1/608 "2025-05-06T15:08:35Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![jgarridoa](https://yyz2.discourse-cdn.com/free1/user_avatar/aiida.discourse.group/jgarridoa/32/56_2.png) [@jgarridoa](https://aiida.discourse.group/u/jgarridoa)\
**Post date:** [May 6, 2025, 3:08pm UTC](https://aiida.discourse.group/t/unnable-to-connect-to-broker-issue-aiida-2-6-1/608/1 "2025-05-06T15:08:35Z")

</div>

Dear everyone

I am using Aiida 2.6.1. After a power shortage, my computer turned off. After restarting, I had to turn on again the database and Rabbitmq. This is my `verdi status` output:

```auto
(aiida) jgarridoa@fatnode-tacn:~$ verdi status
 ✔ version: AiiDA v2.6.1
 ✔ config: /home/ICN2/jgarridoa/.aiida
 ✔ profile: presto
 ✔ storage: Storage for 'presto' [open] @ postgresql://aiida-presto_2:***@localhost:5432/aiida-presto / DiskObjectStoreRepository: c613722add2447e9ab6163be1da50d76 | /home/ICN2/jgarridoa/.aiida/repository/presto/container
 ✘ broker: Unable to connect to broker: RabbitMQ @ amqp://guest:guest@127.0.0.1:5672?heartbeat=600 <Connection failed>
Error: ConnectionError: [Errno 111] Connect call failed ('127.0.0.1', 5672)
 ⏺ daemon: The daemon is not running.

```

Writing `rabbitmq-server` (without the -d option) I get:

```auto
(aiida) jgarridoa@fatnode-tacn:~$ rabbitmq-server
2025-05-06 15:00:37.834646+00:00 [error] <0.216.0> Feature flags: `restart_streams`: required feature flag not enabled! It must be enabled before upgrading RabbitMQ.
2025-05-06 15:00:37.848853+00:00 [error] <0.216.0> Failed to initialize feature flags registry: {disabled_required_feature_flag,
2025-05-06 15:00:37.848853+00:00 [error] <0.216.0> restart_streams}
2025-05-06 15:00:37.866794+00:00 [error] <0.216.0>
2025-05-06 15:00:37.866794+00:00 [error] <0.216.0> BOOT FAILED
2025-05-06 15:00:37.866794+00:00 [error] <0.216.0> ===========
2025-05-06 15:00:37.866794+00:00 [error] <0.216.0> Error during startup: {error,failed_to_initialize_feature_flags_registry}
2025-05-06 15:00:37.866794+00:00 [error] <0.216.0>

BOOT FAILED
===========
Error during startup: {error,failed_to_initialize_feature_flags_registry}

2025-05-06 15:00:38.867788+00:00 [notice] <0.45.0> Application rabbit exited with reason: {failed_to_initialize_feature_flags_registry,{rabbit,start,[normal,[]]}}
{exit,terminating,[{application_controller,call,2,[{file,"application_controller.erl"},{line,511}]},{application,'-ensure_all_started/3-lc$^0/1-0-',1,[{file,"application.erl"},{line,367}]},{application,ensure_all_started,3,[{file,"application.erl"},{line,367}]},{rabbit,'-start_it/1-fun-0-',1,[{file,"rabbit.erl"},{line,430}]},{timer,tc,2,[{file,"timer.erl"},{line,595}]},{rabbit,start_it,1,[{file,"rabbit.erl"},{line,426}]},{init,start_it,1,[]},{init,start_em,1,[]}]}
Runtime terminating during boot (terminating)

Crash dump is being written to: erl_crash.dump...done
[os_mon] cpu supervisor port (cpu_sup): Erlang has closed
[os_mon] memory supervisor port (memsup): Erlang has closed

```

As you can see, rabbitmq is showing some errors about feature flags.

Does anybody know how should I proceed to be able to connect to the broker again?

Thanks in advance

Jaime

---

<div class="post-metadata">

**Author:** ![giovannipizzi](https://yyz2.discourse-cdn.com/free1/user_avatar/aiida.discourse.group/giovannipizzi/32/17_2.png) [@giovannipizzi](https://aiida.discourse.group/u/giovannipizzi)\
**Post date:** [May 6, 2025, 8:15pm UTC](https://aiida.discourse.group/t/unnable-to-connect-to-broker-issue-aiida-2-6-1/608/2 "2025-05-06T20:15:24Z")

</div>

Hello, it sounds that at some point since your last running of RabbitMQ, you upgraded it. Is it possible? How did you install it? (Operating System, and which method - system-wide, conda, …).

If it happened, according to online information you have to downgrade to the previous version you had, start that old version of rabbitmq, then run `rabbitmqctl enable_feature_flag restart_streams` (then you can check it’s enabled with `rabbitmqctl list_feature_flags`), stop rabbitmq and only at that point you can upgrade it again. Hope it helps!
